Customers unable to login into the portal
Incident Report for SIP Trunk
Resolved
This incident has been resolved.
Posted Jul 29, 2024 - 16:36 EDT
Investigating
We are looking into an issue with customers unable to login into https://login.siptrunk.com/
Posted Jul 29, 2024 - 16:22 EDT
This incident affected: Management Portal.