DID editing

Incident Report for SIP Trunk

Resolved

This incident has been resolved.
Posted Sep 25, 2023 - 15:11 EDT

Investigating

We are investigating an issue that customers are unable to edit DIDs.
Posted Sep 25, 2023 - 12:19 EDT
This incident affected: Management Portal.